NetBeans IDE 7.1发布

On 2012年01月6日, in soft, by netoearth

NetBeans IDE 7.1 is the first IDE to provide tools for developing with JavaFX 2.0. Aside from that, many other new features and enhancements are provided. 

Release Highlights

  • First to Support JavaFX 2.0
  • UI Debugger for JavaFX and Swing
  • Enhanced Java Editor
  • WebLogic 12c and GlassFish 3.1.1
  • Industry leading Maven support
  • Git integration
  • Improved PHP support
  • New Java EE Features

Further Information

NetBeans IDE 7.1 Release Notes

Oracle Press Release

NetBeans IDE 7.1 introduces support for JavaFX 2.0 by enabling the full compile/debug/profile development cycle for JavaFX 2.0 applications. The release also provides significant Swing GUI Builder enhancements, CSS3 support, and tools for visual debugging of Swing and JavaFX user interfaces. Additional highlights include Git support integrated into the IDE, new PHP debugging features, various JavaEE and Maven improvements, and more.

 

NetBeans IDE 7.1 is available in English, Brazilian Portuguese, Japanese, Russian, and Simplified Chinese.

 

Get the NetBeans IDE 7.1


Download NetBeans IDE 7.1

To use JavaFX 2.0 support, download the JavaFX 2.0 SDK from JavaFX.com

NetBeans IDE 7.1 is a significant update to NetBeans IDE 7.0.1 and includes the following changes:

  • JavaFX 2.0.2 SDK support
  • Batch refactoring tool for bulk changes in Java Editor
  • New UI Debugger for JavaFX and Swing
  • Support for GlassFish 3.1.1 and WebLogic 12c
  • Improved support for CDI, EJB, JSF, Spring, Web Services
  • Subversion and Mercurial enhancements and bundled Git support
  • Maven enhancements
  • PHP enhancements

For more about this release, see the NetBeans IDE 7.1 Release Information page.

Supported Technologies

NetBeans IDE 7.1 supports the following technologies and has been tested with the following application servers. If you plan to use versions other than those explicitly listed, please note that you may encounter unpredictable IDE behavior. See the NetBeans IDE 7.1 Supported Platforms page for more details on the tested platforms and runtimes for this release.

Supported technologies:
  • Java EE 6, Java EE 5 and J2EE 1.4
  • JavaFX 2.0.2
  • Java ME SDK 3.0
  • Java Card 3 SDK
  • Struts 1.3.8
  • Spring 3.0, 2.5
  • Hibernate 3.2.5
  • Java API for RESTful Web Services (JAX-RS) 1.1
  • Java Wireless Toolkit 2.5.2 for CLDC
  • Issue Tracking
    • Bugzilla 4.0.x and earlier
    • Jira 4.2 and earlier
  • PHP 5.3, 5.2, 5.1
  • Groovy 1.6.4
  • Grails 1.1
  • Apache Ant 1.8.2
  • Apache Maven 3.0.3 or later
  • C/C++/Fortran
  • VCS
    • Subversion: 1.5.x, 1.6.x
    • Mercurial: 1.8 and earlier
    • ClearCase V7.0
    • Git 1.7.х

 

Tested application servers:
  • GlassFish Server Open Source Edition 3.1.1
  • WebLogic 12c

 

Known to run application servers:
  • GlassFish Enterprise Server v2.1.1
  • Tomcat 7.0.22
  • JBoss 6.0

System Requirements

NetBeans IDE runs on operating systems that support the Java VM (Virtual Machine) and has been tested on the platforms listed below.

Note: The IDE’s minimum screen resolution is 1024×768 pixels.

Supported Operating Systems

Minimum Hardware Configurations

  • Microsoft Windows XP Professional SP3/Vista SP1/Windows 7 Professional:
    • Processor: 800MHz Intel Pentium III or equivalent
    • Memory: 512 MB
    • Disk space: 750 MB of free disk space
  • Ubuntu 9.10:
    • Processor: 800MHz Intel Pentium III or equivalent
    • Memory: 512 MB
    • Disk space: 650 MB of free disk space
  • Solaris OS version 11 Express (SPARC):
    • Processor: UltraSPARC II 450 MHz
    • Memory: 512 MB
    • Disk space: 650 MB of free disk space
  • Solaris OS version 11 Express (x86/x64 Platform Edition):
    • Processor: AMD Opteron 1200 Series 1.8 GHz
    • Memory: 512 MB
    • Disk space: 650 MB of free disk space
  • Macintosh OS X 10.6 Intel:
    • Processor: Dual-Core Intel (32 or 64-bit)
    • Memory: 1 GB
    • Disk space: 650 MB of free disk space

Recommended Hardware Configurations

  • Microsoft Windows XP Professional SP3/Vista SP1/Windows 7 Professional:
    • Processor: 2.6 GHz Intel Pentium IV or equivalent
    • Memory: 2 GB
    • Disk space: 1 GB of free disk space
  • Ubuntu 11.04:
    • Processor: 2.6 GHz Intel Pentium IV or equivalent
    • Memory: 2 GB
    • Disk space: 850 MB of free disk space
  • Solaris OS version 11 Express (SPARC):
    • Processor: UltraSPARC IIIi 1 GHz
    • Memory: 2 GB
    • Disk space: 850 MB of free disk space
  • Solaris OS version 11 Express (x86/x64 platform edition):
    • Processor: AMD Opteron 1200 Series 2.8 GHz
    • Memory: 2 GB
    • Disk space: 850 MB of free disk space
  • Macintosh OS X 10.7 Intel:
    • Processor: Dual-Core Intel (32 or 64-bit)
    • Memory: 2 GB
    • Disk space: 850 MB of free disk space

 

NetBeans IDE is also known to run on the various other Linux distributions such as Oracle Linux 5, Ubuntu 8.x, Red Hat Enterprise Linux, Fedora 14, and many others.

Note: NetBeans Web and Java EE support are particularly demanding on system resources – especially when used in combination with application servers. While the above system requirements apply to most configurations of the IDE, for the best results make sure that your system meets at least the recommended system requirements when developing Web and Java EE applications.

Required Software

NetBeans IDE runs on the Java SE Development Kit (JDK) which consists of the Java Runtime Environment plus developer tools for compiling, debugging, and running applications written in the Java language.

The tested JDK for this release is JDK 7. The 7.1 version of the IDE cannot be installed or run using JDK 5.0.

Note: The PHP and C/C++ NetBeans bundles only require the Java Runtime Environment (JRE) 6 to be installed and run.

 

You can download the JDK for your platform from one of the sites listed below:

top

JavaFX Support

The JavaFX 2.0.2 SDK is not bundled with the NetBeans IDE 7.1 release. You can download it from http://javafx.com/downloads/.
Please note the following:

  • The minimum supported JDK version for JavaFX 2.0.2 is JDK 6 Update 26 for Windows and Mac OS X.
  • See the JavaFX 2.0 System Requirements page for more information about system requirements and supported platforms in the JavaFX SDK.
  • Check JavaFX 2.0.2 Release Notes for the list of known issues with the JavaFX 2.0.2 code or documentation.
  • The FX project file format has been substantially updated from the 7.1 Beta format and may cause problems for users who attempt to open 7.1 Beta FX projects in NetBeans IDE 7.1. See issue #205249 for details.

top

SQL Editor and Databases

The following changes have been made to the database functionality in NetBeans IDE 7.1:

  • Upgraded Drivers. The MySQL drivers included in NetBeans IDE have been updated to version 6.0.
  • Tested DriversNetBeans IDE 7.1 has been tested with the following databases and drivers.
    Driver
    Version
    Example URL
    JavaDB Derby 10.3.1.4 jdbc:derby://localhost:1527/sample (Network)
    Oracle Oracle Database 11g (11.1.0.7) jdbc:oracle:thin:@//localhost:1521:ora11i
  • Other DriversThe following drivers and databases have not been formally tested, but should work based on experience.
    Driver
    Version
    Example URL
    PostgreSQL 8.x jdbc:postgresql://jsmith.mycompany.com:5432/postgres
    MySQL MySQL Connector/J 6.0 jdbc:mysql://localhost:3306/sample
    Microsoft Microsoft SQL Server 2005 JDBC Driver 1.2.2828.100 jdbc:sqlserver://localhost:1433;databaseName=travel;selectMethod=cursor
    IBM Redistributable DB2 JDBC Type 4 driver v8 fixpack 13 jdbc:db2://localhost:50002/sample
    jTDS jTDS 1.2.1 jdbc:jtds:sqlserver://test-mycompany.com:1433/travel
    DataDirect DataDirect Connect for JDBC – 3.6 DataDirect Connect for JDBC – 3.6.07 jdbc:datadirect:oracle://localhost;SID=ora11ijdbc:datadirect:sqlserver://localhost:1433;DatabaseName=travel;SelectMethod=cursorjdbc:datadirect:db2://localhost:50002;databaseName=sample
  • For Database troubleshooting information please refer to the NetBeans Database Connectivity User FAQ.
Tagged with:  

Comments are closed.